OS X Command Line Tools
Obviously, i mean OS X-specific tools, not the unix stuff.
- open - "open files and directories", like you double-clicked on
them, or dragged and dropped onto a specific app
- ditto - "copy files and directories to a destination directory", ie
Mac-savvy cp, which knows about resource forks and HFS metadata and
such; will also read and write zip and cpio archives, and has a few
bells and whistles (although many handy things cp can do are
missing)
- hdiutil - "manipulate disk images", see also hdid
- lsof - "list open files"; this one's from unix, i think, but it's a
hell of a tool nonetheless, hell of a tool (key flags: -p selects
a particular process to list, -i lists only network sockets, and most
importantly, -a causes the selections to be ANDed rather than ORed,
which would be stupid)
- ps - not even remotely an OS X-specific tool, but something you
should know is that you need to say ps -x to list all your processes,
rather than just ps, because by default, ps doesn't list processes that
aren't attatched to a terminal, which on a GUI OS like OS X is most of
them
- osascript - "execute AppleScripts and other OSA language scripts",
ie applescripts only
- say - "Convert text to audible speech", hours of fun!
- enable, disable - "stop/start printers and classes", could be
handy
- GetFileInfo - "get attributes of HFS+ files"
- lsbom - read Bill Of Materials files, as used in the official
OS X installer
- bless, softwareupdate, screencapture
Also, the bash version of where is whereis.